Author Topic: Search broken?  (Read 1285 times)

0 Members and 1 Guest are viewing this topic.

Offline tibaltfox

  • Orange Level
  • *
  • Posts: 193
  • Candies: 21
  • TOFUMONKK
  • Fursona Species: Fox
Search broken?
« on: July 12, 2010, 07:02:39 pm »
Apologies if this has already been addressed. I tried to search for it, but, you know.. I couldn't :P

At first I thought it was just a me-problem, something temporary, but now that it's continuing across multiple platforms and browsers I'm wondering if it's a broader issue.

Search box does not work for me. It returns the following error:
"The database value you're trying to insert does not exist: id_search"

I am currently running CrunchBang Linux 9.04.1 and using Chromium. However, the problem for me seems echoed on both Firefox and Chromium, not just on CrunchBang/Ubuntu but on Fedora 13 as well (OS info is probably irrelevant, but for the sake of debugging and in case I am, indeed, the only one experiencing this issue, thought I'd mention it anyways).
Trust me. I'm a homosexual a bag of cheese a cult leader satan made of DIAMONDS a doctor a furry.

Behance! (Design and photography stuffs)
This FurAffinity account I never use! (which is generally horribly out of date, ahem)

Offline Renegade-Sandwich

  • WHENS MAHVEL?
  • Green Level
  • *
  • Posts: 508
  • Candies: 20
  • Dedotated Wam
    • FurAffinity - Renegade-Sandwich
  • Fursona Species: Gryphon العنقاء
Re: Search broken?
« Reply #1 on: July 12, 2010, 07:09:58 pm »
that happens to me to. I have no idea why.
Skype: xherpxderpx

Offline TIGER

  • Blue Level
  • *
  • Posts: 1723
  • Candies: 222
  • :03
    • Twitter - tidaltiger
    • tumblr
  • Fursona Species: surprisingly, not a tiger?
Re: Search broken?
« Reply #2 on: July 12, 2010, 07:11:30 pm »
I noticed this a while ago, and then it worked for like a day, and then it didn't again.
  • Site Donor
  • Pride Flag - gay
  • Pronouns: she/they
  • Award - Graphic Artist
do your best today! ☀

Offline lucien

  • i sold my hands for food
  • Purple Level
  • *
  • Posts: 2274
  • Candies: 204
  • so please feed me.
    • DeviantArt - m0rtuum
    • FurAffinity - spazzeh
    • Twitter - onlygxdforgives
  • Fursona Species: african lion
Re: Search broken?
« Reply #3 on: July 12, 2010, 07:16:12 pm »
This has been happening to me, too. Figured it was just my wonky connection.
  • Award - Beta Tester
  • Pride Flag - transgender
  • Pride Flag - gay
  • Pronouns: he/him

Offline Kambo

  • Personally knew Abe Lincoln
  • Blue Level
  • *
  • Posts: 1801
  • Candies: 85
  • True story.
    • DeviantArt - kamboblack
    • FurAffinity - harlan
    • Twitter - kamboblack
    • Weasyl - harlan
    • Unfinished Portfolio Site :(
  • Fursona Species: Grey fox
Re: Search broken?
« Reply #4 on: July 12, 2010, 07:19:48 pm »
It happens with me occasionally, just on and off.

I'm using the latest version (whatever that is) of Firefox on 64-bit Vista Ultimate.
« Last Edit: July 12, 2010, 07:33:15 pm by Harlan »
  • Award - Beta Tester
  • Pronouns: He/Him/His
Feel free to PM me, I don't bite! I reserve that treatment for sushi and pretzels.

Fursona References (Kambo and Camille)

Offline Sigurd

  • Blue Level
  • *
  • Posts: 1004
  • Candies: 78
  • bluh bluh
  • Fursona Species: a gay
Re: Search broken?
« Reply #5 on: July 12, 2010, 07:25:16 pm »
Honestly guys, replying to this thread stating that it's "Happened to you before too" isn't going to help any at all. At least tell us what Browser you're running or something like that so it makes our lives easier. While this too has happened to me, and I use Firefox, it only happens when I search something that isn't really a word.

Ex: I search "Lucky" and stuff came up. I then searched "lol" and got the error.

This could also be because people are searching at the same time and could cause a problem, but that's just a wild guess.
  • Award - Beta Tester

Offline Meadow Whisper (Natasha)

  • ᎣᏏᏲ! I'm a horse now! ^.^
  • FT Founder
  • *
  • Posts: 4409
  • Candies: 397
  • Avatar by Fawn! :D
    • DeviantArt - lupiniastudios
    • FurAffinity - softpaw
    • Twitter - lupinia
    • Weasyl - softpaw
    • Lupinia Studios
  • Fursona Species: Chincoteague Pony
Re: Search broken?
« Reply #6 on: July 12, 2010, 07:26:15 pm »
I never use the search function, so I never noticed this, it's probably been broken since the upgrade.  I just looked into it, and I should be able to fix it soon-ish.

This is why I keep saying if something is broken, tell me about it, never assume that I already know.  Because, most likely, I don't already know; you wouldn't have seen it broken if I did.


Honestly guys, replying to this thread stating that it's "Happened to you before too" isn't going to help any at all. At least tell us what Browser you're running or something like that so it makes our lives easier. While this too has happened to me, and I use Firefox, it only happens when I search something that isn't really a word.

Ex: I search "Lucky" and stuff came up. I then searched "lol" and got the error.

This could also be because people are searching at the same time and could cause a problem, but that's just a wild guess.

While the first part is excellent advice, in this case it's a server-side issue caused by the manual intervention I had to do to get the upgrade to work, so browser information is irrelevant.  Basically, there's a difference in database structure between versions that I didn't correct for when I had to essentially restructure the database tables manually.
« Last Edit: July 12, 2010, 07:28:31 pm by Svetlana Solovyov »
  • Award - Beta Tester
  • Site Donor
  • Pride Flag - transgender
  • Pride Flag - gay
  • Pronouns: She/Her/Hers
Here is a horse I have made for you:
        |,\_/,\_
 ,-__/,   ,       )kk
.                     \,kkk
 \    ,___....--     \kkkk
           \               \kkkkk
             \               \kkkkk

Note:  I'm no longer actively involved in running this site, so while I welcome any personal messages, please do not contact me about account issues.  Please direct all such inquiries to Panda.  Thanks for all the years of awesome memories and friendship!  <3

Offline tibaltfox

  • Orange Level
  • *
  • Posts: 193
  • Candies: 21
  • TOFUMONKK
  • Fursona Species: Fox
Re: Search broken?
« Reply #7 on: July 12, 2010, 07:32:08 pm »
I never use the search function, so I never noticed this, it's probably been broken since the upgrade.  I just looked into it, and I should be able to fix it soon-ish.

This is why I keep saying if something is broken, tell me about it, never assume that I already know.  Because, most likely, I don't already know; you wouldn't have seen it broken if I did.


Honestly guys, replying to this thread stating that it's "Happened to you before too" isn't going to help any at all. At least tell us what Browser you're running or something like that so it makes our lives easier. While this too has happened to me, and I use Firefox, it only happens when I search something that isn't really a word.

Ex: I search "Lucky" and stuff came up. I then searched "lol" and got the error.

This could also be because people are searching at the same time and could cause a problem, but that's just a wild guess.

While the first part is excellent advice, in this case it's a server-side issue caused by the manual intervention I had to do to get the upgrade to work, so browser information is irrelevant.  Basically, there's a difference in database structure between versions that I didn't correct for when I had to essentially restructure the database tables manually.

At first, like many people here, I thought it was just some strange client-side thing going on. Especially seeing as I hadn't heard any complaints from any one else on the matter.
But, given the choir of 'amens!' received here, server side makes sense :P

Yay for fixinz!
I think Ms. Natasha deserves a round of applause,
for, you know, being an awesome admin and stretching herself well beyond her means..
like, I dunno, some thick, invulnerable rubber band..
OF AWESOME THINGS.

Thanks Natasha. No rush :3.
*claps*
« Last Edit: July 12, 2010, 10:06:15 pm by tibaltfox »
Trust me. I'm a homosexual a bag of cheese a cult leader satan made of DIAMONDS a doctor a furry.

Behance! (Design and photography stuffs)
This FurAffinity account I never use! (which is generally horribly out of date, ahem)

Offline copb.phoenix

  • So long and goodnight
  • Purple Level
  • *
  • Posts: 2229
  • Candies: 114
    • FurAffinity - copb_phoenix
Re: Search broken?
« Reply #8 on: July 31, 2010, 10:35:47 am »
And again, I get this error.

Tried "youtube videos"
  • Flag - turing
  • Award - Beta Tester
Isn't this where...?

Offline Flaeme

  • Orange Level
  • *
  • Posts: 113
  • Candies: 8
    • DeviantArt - flaeme
    • FurAffinity - flaeme
    • Twitter - FlaemeFlow
    • ./Flaeme\'s_Code_and_Rants
  • Fursona Species: Fox in a Winged Wolf's Body
Re: Search broken?
« Reply #9 on: August 17, 2010, 10:11:41 pm »
It only happens when I search site-wide.  If I searchfor collar in General Chatter, I find the collar thread.If I search site-wide, I get the error. To search in general chatter, you go to General Chatter and search, just to clarify.

Offline Meadow Whisper (Natasha)

  • ᎣᏏᏲ! I'm a horse now! ^.^
  • FT Founder
  • *
  • Posts: 4409
  • Candies: 397
  • Avatar by Fawn! :D
    • DeviantArt - lupiniastudios
    • FurAffinity - softpaw
    • Twitter - lupinia
    • Weasyl - softpaw
    • Lupinia Studios
  • Fursona Species: Chincoteague Pony
Re: Search broken?
« Reply #10 on: August 23, 2010, 12:10:39 am »
This has been fixed.  Let me know if it's still an issue.

And, even though no one ever listens to me, PLEASE report ANY problems you encounter anywhere else on the site, because I can't fix it if I don't know about it.  NEVER assume I'm already aware unless there's a thread about it, or unless you've talked to me directly about it.  There are few things that anger me more quickly than finding out that something on the site has been broken for months and not a single person told me about it; seeing a thread pop up with a bunch of people having the same problem, who never told me it was a problem, makes this much worse.
  • Award - Beta Tester
  • Site Donor
  • Pride Flag - transgender
  • Pride Flag - gay
  • Pronouns: She/Her/Hers
Here is a horse I have made for you:
        |,\_/,\_
 ,-__/,   ,       )kk
.                     \,kkk
 \    ,___....--     \kkkk
           \               \kkkkk
             \               \kkkkk

Note:  I'm no longer actively involved in running this site, so while I welcome any personal messages, please do not contact me about account issues.  Please direct all such inquiries to Panda.  Thanks for all the years of awesome memories and friendship!  <3

Offline tibaltfox

  • Orange Level
  • *
  • Posts: 193
  • Candies: 21
  • TOFUMONKK
  • Fursona Species: Fox
Re: Search broken?
« Reply #11 on: August 23, 2010, 02:08:01 am »
This has been fixed.  Let me know if it's still an issue.

And, even though no one ever listens to me, PLEASE report ANY problems you encounter anywhere else on the site, because I can't fix it if I don't know about it.  NEVER assume I'm already aware unless there's a thread about it, or unless you've talked to me directly about it.  There are few things that anger me more quickly than finding out that something on the site has been broken for months and not a single person told me about it; seeing a thread pop up with a bunch of people having the same problem, who never told me it was a problem, makes this much worse.

We're sorry Natasha! *bakes you cookies*
People probably just don't want to bother you, having the best intentions at heart and all :3

Ladies and gentleman, we have search!
*cheers*
Trust me. I'm a homosexual a bag of cheese a cult leader satan made of DIAMONDS a doctor a furry.

Behance! (Design and photography stuffs)
This FurAffinity account I never use! (which is generally horribly out of date, ahem)